blob: a6ed2e83260e4db5747b925815030922dd94677b [file] [log] [blame]
Patrick Williams0450a022022-10-07 21:23:47 -05001SUMMARY = "Phosphor DBUS Object Manager"
2DESCRIPTION = "Phosphor DBUS object manager."
3HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
6DEPENDS += "systemd"
7DEPENDS += "boost"
8DEPENDS += "libtinyxml2"
9DEPENDS += "sdbusplus"
10DEPENDS += "phosphor-logging"
11DEPENDS += "cli11"
Andrew Geissler691eea12022-12-08 10:40:07 -060012SRCREV = "fffd34daac3d6d1882c58f46a2c5ac15bbc3d0a5"
Patrick Williams0450a022022-10-07 21:23:47 -050013PV = "1.0+git${SRCPV}"
14PR = "r1"
15
16SRC_URI += "git://github.com/openbmc/phosphor-objmgr;branch=master;protocol=https"
17
18SYSTEMD_SERVICE:${PN} += " \
19 mapper-wait@.service \
20 mapper-subtree-remove@.service \
21 "
22S = "${WORKDIR}/git"
23
24inherit meson pkgconfig
25inherit obmc-phosphor-dbus-service
26inherit obmc-phosphor-systemd
27
28EXTRA_OEMESON += "-Dtests=disabled"
29
30PROVIDES += "libmapper"
31PACKAGE_BEFORE_PN += "libmapper"
32FILES:libmapper = "${libdir}/lib*.so*"
33
34DBUS_SERVICE:${PN} += "xyz.openbmc_project.ObjectMapper.service"