blob: 887558d962b9a8a5bc5f6d00899120bbfa06ce68 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001SUMMARY = "Building and installing bootgen"
2DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images"
3
4LICENSE = "Apache-2.0"
Andrew Geissler7eb438a2020-11-30 19:53:16 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=d526b6d0807bf263b97da1da876f39b1"
Andrew Geissler84ad7c52020-06-27 00:00:16 -05006
7S = "${WORKDIR}/git"
8
9DEPENDS += "openssl"
10RDEPENDS_${PN} += "openssl"
11
12REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https"
13BRANCH ?= "master"
Andrew Geissler7eb438a2020-11-30 19:53:16 -060014SRCREV ?= "465e32423aa6ba2d71f51c4ae0602cfeb022af08"
Andrew Geissler84ad7c52020-06-27 00:00:16 -050015
16BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
17SRC_URI = "${REPO};${BRANCHARG}"
18
19EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}'
20CXXFLAGS_append = " -std=c++0x"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24do_install() {
25 install -d ${D}${bindir}
26 install -Dm 0755 ${S}/bootgen ${D}${bindir}
27}
28
29FILES_${PN} = "${bindir}/bootgen"
30
31BBCLASSEXTEND = "native nativesdk"