blob: 6970f51984bf7553bde029e1cca13863393dd106 [file] [log] [blame]
Willy Tu89505a02021-02-12 12:16:25 -08001PR = "r1"
2PV = "0.1+git${SRCPV}"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4"
5
6SRC_URI = "git://github.com/mstpd/mstpd"
7SRCREV = "973c403c79f3d419d9e93a242766ddf0099d1299"
8S = "${WORKDIR}/git"
9
10SRC_URI += "file://bridge-stp"
11SRC_URI += "file://mstpd.service"
12
13inherit autotools pkgconfig systemd
14
15PACKAGES =+ "${PN}-mstpd"
Willy Tu4dd03ca2021-08-06 09:37:35 -070016FILES:${PN}-mstpd = "${sbindir}/mstpd ${sbindir}/mstpctl /sbin/bridge-stp"
Willy Tu89505a02021-02-12 12:16:25 -080017
18SYSTEMD_PACKAGES = "${PN}-mstpd"
Willy Tu4dd03ca2021-08-06 09:37:35 -070019SYSTEMD_SERVICE:${PN}-mstpd = "mstpd.service"
Willy Tu89505a02021-02-12 12:16:25 -080020
Willy Tu4dd03ca2021-08-06 09:37:35 -070021do_install:append() {
Willy Tu89505a02021-02-12 12:16:25 -080022 rm -r ${D}${libexecdir}
23
24 install -d -m 0755 ${D}/sbin
25 install -m 0755 ${WORKDIR}/bridge-stp ${D}/sbin
26
27 install -d -m 0755 ${D}${systemd_system_unitdir}
28 install -m 0644 ${WORKDIR}/mstpd.service ${D}${systemd_system_unitdir}/
29}