blob: b8105fc8ddff8233673148424c1630d31bd52119 [file] [log] [blame]
Andrew Geissler82cfa662020-02-17 15:11:03 -06001SUMMARY = "OpenPOWER processor control services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
9RDEPENDS_${PN} += "op-proc-control"
10RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
11
12ALLOW_EMPTY_${PN} = "1"
13
14pkg_postinst_${PN}() {
15 mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
16 mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
17
18 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
19 TARGET="../op-stop-instructions@.service"
20 ln -s $TARGET $LINK
21
22 LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
23 TARGET="../op-cfam-reset.service"
24 ln -s $TARGET $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060025
26 # Only install cfam override if p9 system
27 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
28 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
29 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
30 TARGET="../cfam_override@.service"
31 ln -s $TARGET $LINK
32 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -060033}
34
35pkg_prerm_${PN}() {
36 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
37 rm $LINK
38 LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
39 rm $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060040 # Only uninstall cfam override if p9 system
41 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
42 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
43 rm $LINK
44 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -060045}