blob: 0a0a6075d307a62c8d01ecd678407de57ff740f2 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES_${PN} = "cyassl"
14
15SRC_URI = "https://www.wolfssl.com/wolfssl-${PV}.zip"
16SRC_URI[md5sum] = "6ec08c09e3f51cccbb1686b4fd45f92f"
17SRC_URI[sha256sum] = "4cc318c49580d3b9c361fe258fac6106624aa744f1d34e03977b587766a753ee"
18
19inherit autotools
20
21BBCLASSEXTEND += "native nativesdk"