blob: 76130d58a5f3480e212b3d520820747d3fef9ea6 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
2DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
3configure software source code packages. Autoconf creates a configuration script for a package from a template \
4file that lists the operating system features that the package can use, in the form of M4 macro calls."
5LICENSE = "GPL-3.0-or-later"
6HOMEPAGE = "http://www.gnu.org/software/autoconf/"
7SECTION = "devel"
8DEPENDS = "m4-native autoconf-native automake-native gnu-config-native help2man-native"
9DEPENDS:remove:class-native = "autoconf-native automake-native help2man-native"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=cc3f3a7596cb558bbd9eb7fbaa3ef16c \
12 file://COPYINGv3;md5=1ebbd3e34237af26da5dc08a4e440464"
13
14SRC_URI = " \
15 https://alpha.gnu.org/gnu/autoconf/autoconf-2.72c.tar.gz \
16 file://program_prefix.patch \
17 file://autoreconf-exclude.patch \
18 file://remove-usr-local-lib-from-m4.patch \
19 file://preferbash.patch \
20 file://autotest-automake-result-format.patch \
21 file://man-host-perl.patch \
22 ${BACKPORTS} \
23"
24SRC_URI:append:class-native = " file://no-man.patch"
25
26BACKPORTS = "\
27 file://backports/0001-mention-prototypes-more-prominently-in-NEWS.patch \
28 file://backports/0002-build-run-make-fetch-which-updated-these.patch \
29 file://backports/0003-NEWS-Tighten-up-wording.patch \
30 file://backports/0004-Cater-to-programs-misusing-AC_EGREP_HEADER.patch \
31 file://backports/0006-Fix-timing-bug-on-high-speed-builds.patch \
32 file://backports/0007-Support-underquoted-callers-better.patch \
33 file://backports/0008-New-script-for-building-inside-Guix-containers.patch \
34 file://backports/0009-AC_XENIX_DIR-Rewrite-using-AC_CANONICAL_HOST.patch \
35 file://backports/0010-AC_TYPE_UID_T-Rewrite-using-AC_CHECK_TYPE.patch \
36 file://backports/0011-Make-AC_PROG_GCC_TRADITIONAL-a-compatibility-alias-f.patch \
37 file://backports/0012-Overhaul-AC_TYPE_GETGROUPS-and-AC_FUNC_GETGROUPS.patch \
38 file://backports/0013-Fold-AC_C_STRINGIZE-into-AC_PROG_CC.patch \
39 file://backports/0014-Remove-the-last-few-internal-uses-of-AC_EGREP_CPP.patch \
40 file://backports/0015-Support-circa-early-2022-Gnulib.patch \
41 file://backports/0016-Improve-year2038-largefile-option-processing.patch \
42 file://backports/0017-AC_SYS_YEAR2038-Fix-configure-failure-on-32-bit-ming.patch \
43 file://backports/0018-Document-limitation-of-BusyBox-tr.patch \
44 file://backports/0019-AC_SYS_YEAR2038_REQUIRED-Fix-configure-failure-with-.patch \
45 file://backports/0020-Tone-down-year-2038-changes.patch \
46 file://backports/0021-Port-AC_FUNC_MMAP-to-more-modern-systems.patch \
47 file://backports/0022-Fix-port-of-AC_FUNC_MMAP.patch \
48 file://backports/0023-Improve-AC_SYS_YEAR2038_RECOMMENDED-diagnostic.patch \
49 file://backports/0024-Improve-AC_FUNC_MMAP-comments.patch \
50 file://backports/0025-Fix-AC_SYS_LARGEFILE-on-GNU-Linux-alpha-s390x.patch \
51 file://backports/0026-Modernize-INSTALL.patch \
52 file://backports/0027-doc-fix-broken-cross-refs.patch \
53 file://backports/0028-INSTALL-Clarify-build-host-target-and-the-system-typ.patch \
54 file://backports/0029-Shorten-and-improve-INSTALL.patch \
55"
56
57SRC_URI[sha256sum] = "21b64169c820c6cdf27fc981ca9c2fb615546e5dead92bccf8d92d0784cdd364"
58
59RDEPENDS:${PN} = "m4 gnu-config \
60 perl \
61 perl-module-bytes \
62 perl-module-carp \
63 perl-module-constant \
64 perl-module-data-dumper \
65 perl-module-errno \
66 perl-module-exporter \
67 perl-module-file-basename \
68 perl-module-file-compare \
69 perl-module-file-copy \
70 perl-module-file-find \
71 perl-module-file-glob \
72 perl-module-file-path \
73 perl-module-file-spec \
74 perl-module-file-spec-unix \
75 perl-module-file-stat \
76 perl-module-file-temp \
77 perl-module-getopt-long \
78 perl-module-io-file \
79 perl-module-list-util \
80 perl-module-overloading \
81 perl-module-posix \
82 perl-module-scalar-util \
83 perl-module-symbol \
84 perl-module-thread-queue \
85 perl-module-threads \
86 "
87RDEPENDS:${PN}:class-native = "m4-native gnu-config-native hostperl-runtime-native"
88
89inherit autotools texinfo
90
91PERL = "${USRBINPATH}/perl"
92PERL:class-native = "/usr/bin/env perl"
93PERL:class-nativesdk = "/usr/bin/env perl"
94
95CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
96
97EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
98
99# As autoconf installs its own config.* files, ensure that they're always up to date.
100update_gnu_config() {
101 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/build-aux
102 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/build-aux
103}
104do_configure[prefuncs] += "update_gnu_config"
105
106do_configure:class-native() {
107 oe_runconf
108}
109
110do_install:append() {
111 rm -rf ${D}${datadir}/emacs
112}
113
114BBCLASSEXTEND = "native nativesdk"