blob: d41de2b5992bb3c4fbae6fd6fc128f856a16f085 [file] [log] [blame]
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -05001SUMMARY = "Phosphor certificate manager configuration for an nslcd authority service"
2
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/LICENSE;md5=19407077e42b1ba3d653da313f1f5b4e"
7
Brad Bishop4eceffc2019-03-21 19:08:15 -04008RDEPENDS_${PN} = "phosphor-certificate-manager"
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -05009
10inherit allarch
Marri Devender Rao09a8ceb2018-10-09 07:53:30 -050011
Brad Bishop4eceffc2019-03-21 19:08:15 -040012SRC_URI = "file://env"
13
14do_install() {
15 install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/authority
16}
17
18pkg_postinst_${PN}() {
19 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
20 TARGET="../phosphor-certificate-manager@.service"
21 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
22 ln -s $TARGET $LINK
23}
24
25pkg_prerm_${PN}() {
26 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@authority.service"
27 rm $LINK
28}