blob: 51dcb23d1189eea66be1787348b48e03c4ac7420 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "A a package of utilities for doing and managing mounts of the Linux CIFS filesystem."
2HOMEPAGE = "http://wiki.samba.org/index.php/LinuxCIFS_utils"
3SECTION = "otherosfs"
4LICENSE = "GPLv3 & LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7PV = "6.9"
8
9SRCREV = "9a8c21ad9e4510a83a3a41f7a04f763a4fe9ec09"
10SRC_URI = "git://git.samba.org/cifs-utils.git"
11
12S = "${WORKDIR}/git"
13DEPENDS += "libtalloc"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
17# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install_append is needed
18PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
19# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
20PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
21PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap,keyutils samba"
22PACKAGECONFIG[cifsacl] = "--enable-cifsacl,--disable-cifsacl,samba"
23PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
24
25inherit autotools pkgconfig
26
27do_install_append() {
28 # Remove empty /usr/bin and /usr/sbin directories since the mount helper
29 # is installed to /sbin
30 rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
31}
32
33FILES_${PN} += "${base_libdir}/security"
34FILES_${PN}-dbg += "${base_libdir}/security/.debug"
35RRECOMMENDS_${PN} = "kernel-module-cifs"