blob: c7e872409f9004078f8774fa00c0a407b20502b9 [file] [log] [blame]
Brad Bishop36a3e3e2019-10-02 13:29:27 -04001SUMMARY = "RenderDoc recipe providing renderdoccmd"
2DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
3HOMEPAGE = "https://github.com/baldurk/renderdoc"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9753b1b4fba3261c27d1ce5c1acef667"
6
7SRCREV = "214d85228538e71cc63a0d7fa11dd75b1d56cc81"
8SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
9 file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
10"
11S = "${WORKDIR}/git"
12
13DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
14
15RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
16
Brad Bishop4fe7a132019-10-07 09:34:48 -040017inherit cmake python3native distro_features_check
18
19REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040020
21python __anonymous () {
22 # only works on glibc systems
23 if d.getVar('TCLIBC') != "glibc":
24 raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
25}
26
27COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
28
29EXTRA_OECMAKE += "\
30 -DENABLE_QRENDERDOC=OFF \
31 -DENABLE_PYRENDERDOC=OFF \
32 -DENABLE_RENDERDOCCMD=ON \
33 -DCMAKE_BUILD_TYPE=Release \
34"
35
36FILES_${PN} += "${libdir}"
37FILES_${PN}-dev = "${includedir}"