blob: 1c663f93e165d6ab23cfd6652658ce871bb244c3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "http://live.gnome.org/JsonGlib"
7
8LICENSE = "LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11DEPENDS = "glib-2.0"
12
13GNOMEBASEBUILDCLASS = "meson"
14inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages
15
16SRC_URI += "file://run-ptest"
17SRC_URI[archive.md5sum] = "4d4bb9837f6d31e32d0ce658ae135f68"
18SRC_URI[archive.sha256sum] = "720c5f4379513dc11fd97dc75336eb0c0d3338c53128044d9fabec4374f4bc47"
19
20PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
21
Brad Bishop19323692019-04-05 15:28:33 -040022do_install_append() {
23 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
24 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
25 fi
26}
27
28BBCLASSEXTEND = "native nativesdk"
29
30# Currently it's not possible to disable gettext in Meson, so we need to force
31# this back on.
32USE_NLS_class-native = "yes"