Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, pure-Python full text indexing, search, and spell checking library." |
| 2 | DESCRIPTION = "\ |
| 3 | Whoosh is a fast, featureful full-text indexing and searching library \ |
| 4 | implemented in pure Python. Programmers can use it to easily add search \ |
| 5 | functionality to their applications and websites. Every part of how \ |
| 6 | Whoosh works can be extended or replaced to meet your needs exactly." |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05303186defc6141143629961c7c8a60" |
| 9 | |
| 10 | SRC_URI[md5sum] = "893433e9c0525ac043df33e6e04caab2" |
| 11 | SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b45375dda69" |
| 12 | |
| 13 | PYPI_PACKAGE = "Whoosh" |
| 14 | PYPI_PACKAGE_EXT = "zip" |
| 15 | |
| 16 | inherit ptest pypi setuptools3 |
| 17 | |
| 18 | RDEPENDS_${PN} += " \ |
| 19 | ${PYTHON_PN}-email \ |
| 20 | ${PYTHON_PN}-multiprocessing \ |
| 21 | ${PYTHON_PN}-netclient \ |
| 22 | ${PYTHON_PN}-numbers \ |
| 23 | ${PYTHON_PN}-pickle \ |
| 24 | ${PYTHON_PN}-shell \ |
| 25 | ${PYTHON_PN}-stringold \ |
| 26 | " |
| 27 | |
| 28 | SRC_URI += " \ |
| 29 | file://run-ptest \ |
| 30 | " |
| 31 | |
| 32 | RDEPENDS_${PN}-ptest += " \ |
| 33 | ${PYTHON_PN}-pytest \ |
| 34 | ${PYTHON_PN}-fcntl \ |
| 35 | " |
| 36 | |
| 37 | do_install_ptest() { |
| 38 | install -d ${D}${PTEST_PATH}/tests |
| 39 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 40 | } |