blob: 667e7ccb9056f927bbf9bfca8eaba6085925c68c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require netmap.inc
2
3DEPENDS = "netmap-modules"
4PACKAGE_ARCH = "${MACHINE_ARCH}"
5
6EXTRA_OECONF = "--kernel-dir=${STAGING_KERNEL_BUILDDIR} \
7 --kernel-sources=${STAGING_KERNEL_DIR} \
8 --no-drivers \
9 --disable-generic \
10 --prefix=${prefix} \
11 --destdir=${D} \
12 --cc='${CC}' \
13 --ld='${LD}' \
14 "
15SRC_URI += "file://0001-testmmap-fix-compile-issue-with-gcc-5.x.patch"
16
17do_configure () {
18 cd ${S}/LINUX
19 ./configure ${EXTRA_OECONF}
20}
21
22do_compile () {
23 cd ${S}/LINUX
24 make apps
25}
26
27do_install () {
28 cd ${S}/LINUX
29 make install-apps DESTDIR=${D}
30}
31
32FILES_${PN} += "${bindir}"
33RDEPENDS_${PN} = "kernel-module-netmap"
34RRECOMMENDS_${PN} = "kernel-module-netmap"
Patrick Williamsddad1a12017-02-23 20:36:32 -060035
36# http://errors.yoctoproject.org/Errors/Details/69733/
37PNBLACKLIST[netmap] ?= "BROKEN: Tries to build kernel module and fails, either it should be disabled or there should be dependency on kernel like in netmap-modules"