blob: 905e5618d53b364cda1e797b0ed76982ce88b372 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001SUMMARY = "Apache Thrift"
2DESCRIPTION = "A software framework, for scalable cross-language services development"
3HOMEPAGE = "https://thrift.apache.org/"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e4ed21f679b2aafef26eac82ab0c2cbf"
7
8DEPENDS = "thrift-native boost python libevent flex-native bison-native \
9 glib-2.0 openssl"
10
11SRC_URI = "git://git-wip-us.apache.org/repos/asf/thrift.git;protocol=https \
12 file://0001-Forcibly-disable-check-for-Qt5.patch \
13 file://0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch \
14 file://0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch \
15"
16SRCREV = "61b8a29b0704ccd81b520f2300f5d1bb261fea3e"
17S = "${WORKDIR}/git"
18
19BBCLASSEXTEND = "native nativesdk"
20
21inherit pkgconfig cmake pythonnative
22
23export STAGING_INCDIR
24export STAGING_LIBDIR
25export BUILD_SYS
26export HOST_SYS
27
28EXTRA_OECMAKE = "-DWITH_QT4=OFF -DWITH_QT5=OFF -DBUILD_JAVA=OFF"
29EXTRA_OECMAKE_append_class-native = "\
30 -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_CPP=OFF"
31EXTRA_OECMAKE_append_class-nativesdk = "\
32 -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_PYTHON=OFF"
33
34do_install_append () {
35 ln -sf thrift ${D}/${bindir}/thrift-compiler
36}