blob: 5ecb29ae36045e22f0d37261aa53a63130113bd4 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001require openvswitch.inc
2
3DEPENDS += "virtual/kernel"
4
5RDEPENDS_${PN}-ptest += "\
6 python-logging python-syslog python-argparse python-io \
7 python-fcntl python-shell python-lang python-xml python-math \
8 python-datetime python-netclient python sed \
9 ldd perl-module-socket perl-module-carp perl-module-exporter \
10 perl-module-xsloader python-netserver python-threading \
11 python-resource python-subprocess \
12 "
13
14S = "${WORKDIR}/git"
15PV = "2.5.0+${SRCREV}"
16
17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
18
19SRCREV = "8c0b419a0b9ac0141d6973dcc80306dfc6a83d31"
20SRC_URI += "\
21 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.5 \
22 file://openvswitch-add-more-target-python-substitutions.patch \
23 file://openvswitch-add-ptest-${SRCREV}.patch \
24 file://run-ptest \
25 file://disable_m4_check.patch \
26 file://kernel_module.patch \
27 file://openvswitch-ptest-Fix-python-path.patch \
Brad Bishop66783732017-12-04 02:22:08 -050028 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \
29 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \
Patrick Williamsd849ec72016-08-17 14:59:38 -050030 "
31
32LIC_FILES_CHKSUM = "file://COPYING;md5=247d8817aece26b21a8cd6791b3ea994"
33
34PACKAGECONFIG ?= ""
35PACKAGECONFIG[dpdk] = "--with-dpdk=${STAGING_DIR_TARGET}/opt/dpdk/${TARGET_ARCH}-native-linuxapp-gcc,,dpdk,"
36
37# Don't compile kernel modules by default since it heavily depends on
38# kernel version. Use the in-kernel module for now.
39# distro layers can enable with EXTRA_OECONF_pn_openvswitch += ""
40# EXTRA_OECONF += "--with-linux=${STAGING_KERNEL_BUILDDIR} --with-linux-source=${STAGING_KERNEL_DIR} KARCH=${TARGET_ARCH}"
41
42# silence a warning
43FILES_${PN} += "/lib/modules"
44
45inherit ptest
46
47EXTRA_OEMAKE += "TEST_DEST=${D}${PTEST_PATH} TEST_ROOT=${PTEST_PATH}"
48
49do_install_ptest() {
50 oe_runmake test-install
51}
52
53do_install_append() {
54 oe_runmake modules_install INSTALL_MOD_PATH=${D}
Patrick Williamse69d2352017-02-23 20:56:04 -060055 rm -r ${D}/${localstatedir}/run
Patrick Williamsd849ec72016-08-17 14:59:38 -050056}