blob: 9c4b60f846e3307bece4b7c6d11e00ea3ff7b6d3 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
8
9SRC_URI[md5sum] = "d15843c3fb7db39af80571ee27ec6fad"
10SRC_URI[sha256sum] = "00b0891c678c065446ca59bcee64719d0096d54d6886e6e472aeee2e170ae324"
11
12inherit autotools-brokensep
13
14do_configure_prepend () {
15 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
16 mv ${S}/aclocal.m4 ${S}/acinclude.m4
17 fi
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man1
23
24 oe_runmake 'INSTALLROOT=${D}' install
25}
26
27BBCLASSEXTEND = "native"
28
29DEPENDS = "groff-native"