blob: 8b502febc4c481d9aef14458b0778d2d7d3143bf [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://remove-build-path-in-comments.patch \
11 file://fix_shebang_f2py.patch \
Brad Bishop37a0e4d2017-12-04 01:01:44 -050012 file://d70d37b7c4aa2af3fe879a0d858c54f2aa32a725.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013 ${CONFIGFILESURI} "
14UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/numpy/files/"
15
16CONFIGFILESURI ?= ""
17
18CONFIGFILESURI_aarch64 = " \
19 file://config.h \
20 file://_numpyconfig.h \
21"
22CONFIGFILESURI_arm = " \
23 file://config.h \
24 file://numpyconfig.h \
25"
26CONFIGFILESURI_armeb = " \
27 file://config.h \
28 file://numpyconfig.h \
29"
30CONFIGFILESURI_mipsel = " \
31 file://config.h \
32 file://numpyconfig.h \
33"
34CONFIGFILESURI_x86 = " \
35 file://config.h \
36 file://numpyconfig.h \
37"
38CONFIGFILESURI_x86-64 = " \
39 file://config.h \
40 file://_numpyconfig.h \
41"
42CONFIGFILESURI_mips = " \
43 file://config.h \
44 file://_numpyconfig.h \
45"
46CONFIGFILESURI_powerpc = " \
47 file://config.h \
48 file://_numpyconfig.h \
49"
50CONFIGFILESURI_powerpc64 = " \
51 file://config.h \
52 file://_numpyconfig.h \
53"
54CONFIGFILESURI_mips64 = " \
55 file://config.h \
56 file://_numpyconfig.h \
57"
58CONFIGFILESURI_mips64n32 = " \
59 file://config.h \
60 file://_numpyconfig.h \
61"
62
63S = "${WORKDIR}/numpy-${PV}"
64
65inherit setuptools3
66
67# Make the build fail and replace *config.h with proper one
68# This is a ugly, ugly hack - Koen
69do_compile_prepend_class-target() {
70 ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py build ${DISTUTILS_BUILD_ARGS} || \
71 true
72 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
73}
74
75FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
76
77SRC_URI[md5sum] = "bc56fb9fc2895aa4961802ffbdb31d0b"
78SRC_URI[sha256sum] = "a1d1268d200816bfb9727a7a27b78d8e37ecec2e4d5ebd33eb64e2789e0db43e"
79
80# install what is needed for numpy.test()
81RDEPENDS_${PN} = "python3-unittest \
82 python3-difflib \
83 python3-pprint \
84 python3-pickle \
85 python3-shell \
86 python3-nose \
87 python3-doctest \
88 python3-datetime \
89 python3-distutils \
90 python3-misc \
91 python3-mmap \
92 python3-netclient \
93 python3-numbers \
94 python3-pydoc \
95 python3-pkgutil \
96 python3-email \
97 python3-subprocess \
98 python3-compression \
99 python3-ctypes \
100 python3-threading \
101 python3-textutils \
102"
103
104RDEPENDS_${PN}_class-native = ""
105
106BBCLASSEXTEND = "native nativesdk"