blob: 82e0fa8863b358b6b1f63ba27ae296952f36d597 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "A Pure Python Expect like Module for Python"
2HOMEPAGE = "http://pexpect.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
6
7SRCNAME = "pexpect"
8
9SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10SRC_URI[md5sum] = "8071ec5df0f3d515daedafad672d1632"
11SRC_URI[sha256sum] = "bf6816b8cc8d301a499e7adf338828b39bc7548eb64dbed4dd410ed93d95f853"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
14
15S = "${WORKDIR}/pexpect-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} = "\
20 python-core \
21 python-io \
22 python-terminal \
23 python-resource \
24 python-fcntl \
25 python-ptyprocess \
26"
27
28BBCLASSEXTEND = "nativesdk"