blob: e10f5fd341d2b4dcdffeaec252c6e09e879388e1 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "http://git.infradead.org/users/dedekind/bmap-tools.git"
8SECTION = "console/utils"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "ftp://ftp.infradead.org/pub/${BPN}/${BPN}-${PV}.tgz"
13SRC_URI[md5sum] = "92cdad1cb4dfa0cca7176c8e22752616"
14SRC_URI[sha256sum] = "cc6c7f7dc0a37e2a32deb127308e24e6c4b80bfb54f3803c308efab02bf2d434"
15
16RDEPENDS_${PN} = "python-core python-compression"
17
18inherit setuptools
19
20BBCLASSEXTEND = "native"
21
22do_install_append_class-native() {
23 sed -i -e 's|^#!.*/usr/bin/env python|#! /usr/bin/env nativepython|' ${D}${bindir}/bmaptool
24}