blob: b66c107f45c9b212b242a0e882dacf9d9115426e [file] [log] [blame]
Lei YU50ab1ac2019-10-21 10:39:07 +08001SUMMARY = "Phosphor Power services and utilities"
2DESCRIPTION = "Configure and monitor power supplies, power sequencers, and \
3voltage regulators, and analyzes power devices for faults"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7inherit meson
8inherit pkgconfig
9inherit systemd
10inherit pythonnative
11
12require ${PN}.inc
13
14S = "${WORKDIR}/git"
15
16# TODO: in future when openpower-dbus-interfaces is removed from
17# phosphor-power, remove the dependency here.
18DEPENDS += " \
19 phosphor-logging \
20 openpower-dbus-interfaces \
21 sdbus++-native \
22 sdeventplus \
23 nlohmann-json \
24 "
25
26SEQ_MONITOR_SVC = "pseq-monitor.service"
27SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
28PSU_MONITOR_TMPL = "power-supply-monitor@.service"
29SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC} ${PSU_MONITOR_TMPL}"