blob: dd28e0f9567ac73faa8d716c2c8f18d5e7df65e6 [file] [log] [blame]
Andrew Jeffery858c9712021-05-04 12:46:46 +09301SUMMARY = "Debug trigger"
2DESCRIPTION = "Forcibly crash an unresponsive system to collect debug data"
3HOMEPAGE = "https://github.com/openbmc/debug-trigger"
4
5SRC_URI = "git://github.com/openbmc/debug-trigger"
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10S = "${WORKDIR}/git"
11
12inherit meson
13inherit pkgconfig
14inherit systemd
15
16PR = "r1"
17PV = "0.1+git${SRCPV}"
Andrew Geisslerf1f55242021-06-17 13:20:40 +000018SRCREV = "15fe59cb0fc1430bdd05a85e7c7887ccc4e5c013"
Andrew Jeffery858c9712021-05-04 12:46:46 +093019
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
21
22DEBUG_TRIGGERS ?= ""
23
24PACKAGECONFIG[systemd] = " \
25 -Dsystemd=true, \
26 -Dsystemd=false, \
27 systemd"
28
29PACKAGECONFIG[triggers] = " \
30 -Dtriggers=${DEBUG_TRIGGERS}, \
31 -Dtriggers=[], \
32 systemd udev"
33
34SYSTEMD_SERVICE_${PN} += "debug-trigger@.service"