blob: ce02a507da1736dd0719cc0bc05551dfef2004a3 [file] [log] [blame]
Patrick Williams7784c422022-11-17 07:29:11 -06001SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME"
2LICENSE = "LGPL-2.0-or-later"
3LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_check
8
9DEPENDS = "gtk+3 gtk+3-native gdk-pixbuf dbus json-glib libxml2 webkitgtk glib-2.0 rest libsecret"
10
Andrew Geissler517393d2023-01-13 08:55:19 -060011SRC_URI += "file://0001-build-Use-the-appropriate-dependency-object.patch"
Patrick Williams7784c422022-11-17 07:29:11 -060012SRC_URI[archive.sha256sum] = "5e7859ce4858a6b99d3995ed70527d66e297bb90bbf75ec8780fe9da22c1fcaa"
13
14PACKAGECONFIG_SOUP ?= "soup3"
15PACKAGECONFIG ?= "kerberos owncloud lastfm google windows_live ${PACKAGECONFIG_SOUP}"
16
Andrew Geissler517393d2023-01-13 08:55:19 -060017PACKAGECONFIG[kerberos] = "-Dkerberos=true, -Dkerberos=false,krb5 gcr3"
Patrick Williams7784c422022-11-17 07:29:11 -060018PACKAGECONFIG[exchange] = "-Dexchange=true, -Dexchange=false"
19PACKAGECONFIG[google] = "-Dgoogle=true, -Dgoogle=false"
20PACKAGECONFIG[owncloud] = "-Downcloud=true, -Downcloud=false"
21PACKAGECONFIG[windows_live] = "-Dwindows_live=true, -Dwindows_live=false"
22PACKAGECONFIG[lastfm] = "-Dlastfm=true, -Dlastfm=false"
23PACKAGECONFIG[soup2] = ",,libsoup-2.4,,,soup3"
24PACKAGECONFIG[soup3] = ",,libsoup-3.0,,,soup2"
25
26FILES:${PN} += " \
27 ${datadir}/dbus-1 \
28 ${libdir}/goa-1.0/web-extensions/*.so \
29"
30
31# looked into pkg-config file: it is not a bug - they mean it
32FILES:${PN}-dev += "${libdir}/goa-1.0/include"