blob: 14163a1866009e3c306359069022719c2de8f447 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7DEPENDS = " \
8 libxml2-native \
9 gtk4 \
10 mutter \
11 evolution-data-server \
12 gcr \
13 geocode-glib \
14 gjs \
15 gnome-autoar \
16 polkit \
17 libcroco \
18 libsoup-3.0 \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', 'startup-notification', d)} \
20 ibus \
21 gsettings-desktop-schemas \
22"
23
24inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
25
26REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
27
28GTKIC_VERSION = "4"
29GTKDOC_MESON_OPTION = "gtk_doc"
30GIR_MESON_OPTION = ""
31
32# gobject-introspection is mandatory and cannot be configured
33REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
34
35SRC_URI[archive.sha256sum] = "df0444765def1bd0afee9617d2b5919bc79b4db86e7e757ac0e1f73748ec1bdc"
36SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
37
38PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
39PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
40PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false,networkmanager,networkmanager"
41PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
42
43EXTRA_OEMESON = " \
44 -Dgjs_path=${bindir}/gjs \
45 -Dextensions-app:gjs_path=${bindir}/gjs \
46 -Dtests=false \
47 -Dman=false \
48 -Dsoup2=false \
49"
50
51do_install:append() {
52 # fix shebangs
53 for tool in `find ${D}${bindir} -name '*-tool'`; do
54 sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
55 done
56}
57
58GSETTINGS_PACKAGE = "${PN}-gsettings"
59
60FILES:${PN} += " \
61 ${datadir}/metainfo \
62 ${datadir}/dbus-1 \
63 ${datadir}/gnome-control-center \
64 ${datadir}/xdg-desktop-portal \
65 ${systemd_user_unitdir} \
66"
67
68RDEPENDS:${PN} += " \
69 accountsservice \
70 adwaita-icon-theme \
71 adwaita-icon-theme-cursors \
72 gdm-base \
73 gnome-control-center \
74 gnome-backgrounds \
75 gnome-bluetooth \
76 gnome-desktop \
77 gnome-session \
78 gnome-settings-daemon \
79 gnome-shell-gsettings \
80 gsettings-desktop-schemas \
81 librsvg-gtk \
82"
83
84PACKAGES =+ "${PN}-tools ${PN}-gsettings"
85FILES:${PN}-tools = "${bindir}/*-tool"
86RDEPENDS:${PN}-tools = "python3-core"
87