blob: d51a27f01aa7bcb5973b2403064de01a447c6941 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Grilo is a framework forsearching media content from various sources"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4
5DEPENDS = " \
6 libxml2 \
7 glib-2.0 \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gobject-introspection gtk-doc gettext vala
13
14SRC_URI[archive.sha256sum] = "f352acf73665669934270636fede66b52da6801fe20f638c4048ab2678577b2d"
15
16GIR_MESON_OPTION = "enable-introspection"
17GTKDOC_MESON_OPTION = "enable-gtk-doc"
18
19# Note: removing 'net' from PACKAGECONFIG causes
20# | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir".
21PACKAGECONFIG ??= "net"
22
23PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-3.0"
24PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth"
25
26# Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG
27EXTRA_OEMESON = "-Denable-grl-pls=false"
28