blob: 3ada6515f87bf1959c9e3869e01c98dcb63cc332 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SECTION = "x11/wm"
2SUMMARY = "Metacity is the boring window manager for the adult in you"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b4cce53560b8e619ffa7c830fb8761aa \
5 file://src/include/main.h;endline=24;md5=72148ede07a6dadd01de6a882d20a9ad"
6
7PE = "1"
8
9DEPENDS = " \
10 gdk-pixbuf-native \
11 gtk+3 \
12 gsettings-desktop-schemas \
13 startup-notification \
14 libcanberra \
15 libgtop \
16 libxres \
17 libxpresent \
18"
19
20
21# depends on startup-notification which depends on virtual/libx11
22REQUIRED_DISTRO_FEATURES = "x11"
23
24inherit gnomebase gsettings gettext upstream-version-is-even features_check
25
26SRC_URI[archive.sha256sum] = "00ba49f7612088f2b3baeca79c45eb2a30423c2e4a7bea4015872beae25dd6c5"
27SRC_URI += "file://0001-drop-zenity-detection.patch"
28
29PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
30# enable as neccessary until new warnings are dealt with
31PACKAGECONFIG[werror] = "--enable-Werror,--disable-Werror,,"
32
33FILES:${PN} += " \
34 ${datadir}/themes \
35 ${datadir}/gnome-control-center \
36 ${datadir}/gnome\
37"
38
39RDEPENDS:${PN} += "gsettings-desktop-schemas"