blob: 1eecfff4b0494105208ee54e395575c858754e94 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Tepl library eases the development of GtkSourceView-based projects"
2LICENSE = "LGPL-3.0-or-later"
3LIC_FILES_CHKSUM = "file://LICENSES/LGPL-3.0-or-later.txt;md5=c51d3eef3be114124d11349ca0d7e117"
4
5DEPENDS = " \
6 gsettings-desktop-schemas \
7 glib-2.0 \
8 gtk+3 \
9 gtksourceview4 \
10 amtk \
11 libxml2 \
12 uchardet \
13 gtk-doc-native \
14 libxslt-native \
15 docbook-xsl-stylesheets-native \
16 python3-pygments-native \
17"
18
19inherit meson gobject-introspection gettext features_check pkgconfig
20
21
22ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
23SRC_URI = "git://gitlab.gnome.org/swilmet/tepl;protocol=https;branch=main"
24SRCREV = "d1e9cc2e4a0738f68d9002f13724b7239f075844"
25S = "${WORKDIR}/git"
26
27# gobject-introspection is mandatory and cannot be configured
28REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
29GIR_MESON_OPTION = ""
30
31GTKDOC_MESON_OPTION = "gtk_doc"