blob: efb85d77c560f9269933417017bb3e8393d458a1 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Objects and helper methods to help reading and writing AppStream metadata"
2HOMEPAGE = "https://people.freedesktop.org/~hughsient/appstream-glib/index.htm"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = " \
7 curl \
8 gperf-native \
9 glib-2.0 \
10 gtk+3 \
11 libyaml \
12 libarchive \
13 json-glib \
14 gdk-pixbuf \
15 freetype \
16 fontconfig \
17 libstemmer \
18"
19
20inherit meson gobject-introspection gettext bash-completion pkgconfig manpages
21
22SRC_URI = "https://people.freedesktop.org/~hughsient/${BPN}/releases/${BP}.tar.xz"
23SRC_URI[sha256sum] = "71256500add5048d6f08878904708b3d0c3875f402e0adcd358e91d47dcd8b96"
24
25EXTRA_OEMESON = " \
26 -Drpm=false \
27"
28
29PACKAGECONFIG ?= ""
30PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,docbook-xml-dtd4-native docbook-xsl-stylesheets-native libxslt-native"
31
32FILES:${PN} += "${libdir}/asb-plugins-5"
33
34FILES:${PN}-dev += " \
35 ${datadir}/installed-tests \
36 ${datadir}/gettext \
37"
38
39BBCLASSEXTEND = "native"