blob: 050ce1a04c643ef058e029345f65590ba427f9a2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A xdg-desktop-portal backend for gnome."
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = " \
7 glib-2.0-native \
8 gtk4\
9 xdg-desktop-portal \
10 xdg-desktop-portal-gtk \
11 libadwaita \
12 fontconfig \
13 gsettings-desktop-schemas \
14 gnome-desktop \
15 dconf \
16"
17
18RDEPENDS:${PN} = "xdg-desktop-portal xdg-desktop-portal-gtk"
19
20inherit meson pkgconfig gsettings features_check
21
22REQUIRED_DISTRO_FEATURES = "polkit"
23
24SRC_URI = "git://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome.git;protocol=https;nobranch=1"
25
26S = "${WORKDIR}/git"
27SRCREV = "4fd5a8bf16b01c78ed19764415cb26d29aaf7eab"
28
29PACKAGECONFIG ?= ""
30
31PACKAGECONFIG[screenshot] = ",,,gnome-shell"
32PACKAGECONFIG[screencast] = ",,,mutter"
33
34FILES:${PN} += "${systemd_user_unitdir} ${datadir}"