blob: 1e0a90618493f0ee3575ba2fea27018906894cbf [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A backend implementation for xdg-desktop-portal that is using GTK and various pieces of GNOME infrastructure."
2HOMEPAGE = "https://github.com/flatpak/xdg-desktop-portal-gtk"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6DEPENDS = " \
7 glib-2.0-native \
8 gtk+3\
9 xdg-desktop-portal \
10 libadwaita \
11 fontconfig \
12 gsettings-desktop-schemas \
13 gnome-desktop \
14 dconf \
15"
16
17inherit gettext autotools pkgconfig gsettings features_check
18
19REQUIRED_DISTRO_FEATURES = "polkit"
20
21SRC_URI = "git://github.com/flatpak/xdg-desktop-portal-gtk.git;protocol=https;nobranch=1"
22
23S = "${WORKDIR}/git"
24SRCREV = "952005f6a7850a247d286f14838202f506b402b7"
25
26# gdbus-codegen wants to create files in ${B}/src and fails because of missing directory
27do_configure:append() {
28 mkdir -p ${B}/src
29}
30
31# Note: wlroots has its own implementation for screenshot and screencast, but
32# you may want to include the according PACKAGECONFIGS for gnome.
33PACKAGECONFIG ?= "wallpaper appchooser lockdown"
34
35PACKAGECONFIG[screenshot] = "--enable-screenshot,--disable-screenshot,gnome-shell"
36PACKAGECONFIG[screencast] = "--enable-screencast,--disable-screencast,mutter"
37PACKAGECONFIG[wallpaper] = "--enable-wallpaper,--disable-wallpaper,gnome-desktop"
38PACKAGECONFIG[background] = "--enable-background,--disable-background,gnome-shell"
39PACKAGECONFIG[appchooser] = "--enable-appchooser,--disable-appchooser"
40PACKAGECONFIG[lockdown] = "--enable-lockdown,--disable-lockdown"
41
42FILES:${PN} += "${systemd_user_unitdir} ${datadir}"