blob: 0a7680a8c4e76c215aa11b8eb575adaca1bf0694 [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001SUMMARY = "Flite: a small run-time speech synthesis engine"
2HOMEPAGE = "http://cmuflite.org"
3SECTION = "libs/multimedia"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b3b732d1349633a53e69356607fd2d6c"
6
7inherit autotools-brokensep
8
Andrew Geissler517393d2023-01-13 08:55:19 -06009DEPENDS += "alsa-lib chrpath-replacement-native"
10
Andrew Geissler78b72792022-06-14 06:47:25 -050011SRC_URI = "git://github.com/festvox/flite.git;protocol=https;branch=master"
12
13SRCREV = "e9e2e37c329dbe98bfeb27a1828ef9a71fa84f88"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OECONF += "--enable-shared"
18
Andrew Geissler517393d2023-01-13 08:55:19 -060019do_configure:append() {
20 sed -i '/$(INSTALL) -m 755 $(BINDIR)\/flite_time $(DESTDIR)$(INSTALLBINDIR)/d' ${S}/main/Makefile
21}
22
Andrew Geissler78b72792022-06-14 06:47:25 -050023do_install:append() {
24 chown -R root:root ${D}${libdir}/*
25}
Andrew Geissler517393d2023-01-13 08:55:19 -060026# | make[1]: *** No rule to make target 'flite_voice_list.c', needed by 'all'. Stop.
27PARALLEL_MAKE = ""