blob: 48ce2abf094fb0ed5d88a7b9fd0024de89962459 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD is a block device which is designed to build high \
3 availability clusters. This is done by mirroring a whole \
4 block device via (a dedicated) network. You could see \
5 it as a network raid-1."
6HOMEPAGE = "http://oss.linbit.com/drbd/"
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
9DEPENDS = "virtual/kernel"
10
11SRC_URI = "https://pkg.linbit.com//downloads/drbd/9/${BP}.tar.gz \
12 file://check_existence_of_modules_before_installing.patch \
13 "
14SRC_URI[sha256sum] = "f59ee795188f21d4a62c5319c371ebad65ab3fb9b55e5212c3f1dd558978a843"
15
16inherit module
17
18EXTRA_OEMAKE += "KDIR='${STAGING_KERNEL_DIR}' SPAAS=true"
19
20do_install () {
21 oe_runmake install DESTDIR="${D}"
22}
23
24SKIP_RECIPE[drbd] ?= "Needs coccinelle to build with SPAAS"