blob: d4c4f1c371b801b9d35fd76343332dac1b6ddce2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The tdb library"
2HOMEPAGE = "https://tdb.samba.org/"
3SECTION = "libs"
4LICENSE = "LGPL-3.0-or-later & GPL-3.0-or-later"
5
6LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
7 file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
8
9export PYTHONHASHSEED="1"
10
11SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
12 file://0001-tdb-Add-configure-options-for-packages.patch \
13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
14"
15
16SRC_URI[md5sum] = "bc27d5b20c7f013305c40b3bced43b3a"
17SRC_URI[sha256sum] = "a4fb168def533f31ff2c07f7d9844bb3131e6799f094ebe77d0380adc987c20e"
18
19PACKAGECONFIG ??= "\
20 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
22"
23
24PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
25PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
26PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
27PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
28PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
29PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
30
31S = "${WORKDIR}/tdb-${PV}"
32
33inherit waf-samba
34
35#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
36#to cross Popen
37export WAF_NO_PREFORK="yes"
38
39EXTRA_OECONF += "--disable-rpath \
40 --disable-rpath-install \
41 --bundled-libraries=NONE \
42 --builtin-libraries=replace \
43 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
44 "
45
46PACKAGES += "tdb-tools python3-tdb"
47
48RPROVIDES:${PN}-dbg += "python3-tdb-dbg"
49
50FILES:${PN} = "${libdir}/*.so.*"
51FILES:tdb-tools = "${bindir}/*"
52FILES:python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
53RDEPENDS:python3-tdb = "python3"
54INSANE_SKIP:${MLPREFIX}python3-tdb = "dev-so"