blob: 3892a0e21aabb789caa786b393531caac380b44a [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "net"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
10LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
13
14inherit update-alternatives
15
16UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/traceroute/files/traceroute/"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
19"
20SRC_URI[sha256sum] = "8fc8d5046e855d7588607bb319f5b82e3ba13e91d5d4636863262e6386bbaf76"
21
22EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
23LTOEXTRA += "-flto-partition=none"
24
25do_compile() {
26 oe_runmake "env=yes"
27}
28
29do_install() {
30 install -d ${D}${bindir}
31 install -m755 ${BPN}/${BPN} ${D}${bindir}
32
33 install -m755 wrappers/tcptraceroute ${D}${bindir}
34
35 install -d ${D}${mandir}/man8
36 install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}/man8
37 ln -s ${BPN}.8 ${D}${mandir}/man8/${BPN}6.8
38 ln -s ${BPN}.8 ${D}${mandir}/man8/tcptraceroute.8
39
40}
41
42ALTERNATIVE_PRIORITY = "100"
43ALTERNATIVE:${PN} = "traceroute"
44ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"