blob: 897caea2a78761618cd48b1bad65b8c218dced36 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION="Protocol Buffers with small code size"
2LICENSE="Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
4
5DEPENDS = "protobuf-native"
6
7SRC_URI = "git://github.com/nanopb/nanopb.git;branch=master;protocol=https"
8SRCREV = "b97aa657a706d3ba4a9a6ccca7043c9d6fe41cba"
9
10S = "${WORKDIR}/git"
11
12inherit cmake python3native
13
14do_install:append() {
15 install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py
16 install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb
17 install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py
18}
19
20FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
21FILES:${PN}-dev += "${libdir}/cmake/${BPN}"
22
23RDEPENDS:${PN} += "\
24 ${PYTHON_PN}-protobuf \
25 protobuf-compiler \
26"
27
28BBCLASSEXTEND = "native nativesdk"
29