blob: 42cee1108d33833670d33f333fb6fa32512c3f17 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Utility to test for faulty memory subsystem"
2HOMEPAGE = "http://pyropus.ca/software/memtester/"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
7
8SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz \
9 file://Makefile.patch \
10 "
11SRC_URI[sha256sum] = "c9fe4eb7e80c8cef5202f9065c4c0682f5616647c0455e916a5700f98e3dbb2e"
12
13do_compile () {
14 echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
15 echo '${CC} ${LDFLAGS}' > conf-ld
16 oe_runmake
17}
18
19do_install () {
20 install -d ${D}${bindir}
21 install -d ${D}${mandir}/man8
22 install -m 0755 memtester ${D}${bindir}/
23 install -m 0755 memtester.8 ${D}${mandir}/man8/
24}