blob: b2592d294b94fa8741ff0d30991ba54dfd97b7e3 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips"
2LICENSE = "GPL-2.0-or-later"
3HOMEPAGE = "http://flashrom.org"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \
7 file://meson-fixes.patch \
8 file://0001-flashrom-Mark-RISCV-as-non-memory-mapped-I-O-archite.patch \
9 file://0001-hwaccess-use-__asm__-as-is-done-elsewhere.patch \
10 "
11SRC_URI[sha256sum] = "89a7ff5beb08c89b8795bbd253a51b9453547a864c31793302296b56bbc56d65"
12
13S = "${WORKDIR}/flashrom-v${PV}"
14
15inherit meson pkgconfig
16
17PACKAGECONFIG ??= "pci usb ftdi"
18PACKAGECONFIG[pci] = "-Dpciutils=true,-Dpciutils=false,pciutils"
19PACKAGECONFIG[usb] = "-Dusb=true,-Dusb=false,libusb"
20PACKAGECONFIG[ftdi] = "-Dftdi=true,-Dftdi=false,libftdi"