blob: 91450e2c77e730f23ad8591c443fa5bba5c3bfc1 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc"
2HOMEPAGE = "https://github.com/cminyard/gensio"
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \
5 file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \
6 "
7
8SRCREV = "d512218c4fa5667d4fe15977d3f15f05591f1f1a"
9
10SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master"
11
12S = "${WORKDIR}/git"
13
14inherit autotools
15
16PACKAGECONFIG ??= "openssl tcp-wrappers"
17
18PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl"
19PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers"
20PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig"
21
22EXTRA_OECONF = "--without-python"
23
24RDEPENDS:${PN} += "bash"