blob: bf98d561e6ba5b50013b6753848433c07a1c6639 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Cap'n Proto serialization/RPC system"
2DESCRIPTION = "Cap’n Proto is an insanely fast data interchange format and capability-based RPC system. "
3HOMEPAGE = "https://github.com/sandstorm-io/capnproto"
4SECTION = "console/tools"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://../LICENSE;md5=a05663ae6cca874123bf667a60dca8c9"
7
8SRC_URI = "git://github.com/sandstorm-io/capnproto.git;branch=release-0.10.3;protocol=https"
9SRCREV = "a16468f296a9584f4068072efecdee8a9eb9c2ed"
10
11S = "${WORKDIR}/git/c++"
12
13inherit cmake
14
15CXXFLAGS:append:mips = " -latomic"
16CXXFLAGS:append:powerpc = " -latomic"
17CXXFLAGS:append:riscv32 = " -latomic"
18
19EXTRA_OECMAKE += "\
20 -DBUILD_TESTING=OFF \
21"
22
23FILES:${PN}-compiler = "${bindir}"
24
25PACKAGE_BEFORE_PN = "${PN}-compiler"
26RDEPENDS:${PN}-dev += "${PN}-compiler"
27
28BBCLASSEXTEND = "native nativesdk"