blob: 684788f19973151c44f08aedc12ce3a285cc97a6 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Perl module for pseudo tty IO"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
4LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=12;md5=b2562f94907eeb42e8ce9d45f628e587"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/IO/IO-Tty-${PV}.tar.gz \
7 file://0001-Tty.xs-Do-not-mark-strlcpy-as-static.patch \
8 "
9
10SRC_URI[sha256sum] = "a5f1a83020bc5b5dd6c1b570f48c7546e0a8f7fac10a068740b03925ad9e14e8"
11
12S = "${WORKDIR}/IO-Tty-${PV}"
13
14inherit cpan ptest-perl
15
16RDEPENDS:${PN} += "\
17 perl-module-carp \
18 perl-module-exporter \
19 perl-module-io-handle \
20 perl-module-posix \
21"
22
23RDEPENDS:${PN}-ptest += "\
24 perl-module-test-more \
25"
26
27FILES:${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/IO/Tty/.debug/"
28