blob: 814d4b96447ebcea211ba32e55c71415b19a9ef6 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Fast Log processor and Forwarder"
2DESCRIPTION = "Fluent Bit is a data collector, processor and \
3forwarder for Linux. It supports several input sources and \
4backends (destinations) for your data. \
5"
6
7HOMEPAGE = "http://fluentbit.io"
8BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
12SECTION = "net"
13
14SRC_URI = "https://releases.fluentbit.io/1.9/source-${PV}.tar.gz;subdir=fluent-bit-${PV} \
15 file://0001-CMakeLists.txt-Do-not-use-private-makefile-target.patch \
16 file://0002-flb_info.h.in-Do-not-hardcode-compilation-directorie.patch \
17 file://0003-mbedtls-Do-not-overwrite-CFLAGS.patch \
18 file://0004-build-Make-systemd-init-systemd-detection-contingent.patch \
19 file://0001-monkey-Define-_GNU_SOURCE-for-memmem-API-check.patch \
20 file://0002-mbedtls-Remove-unused-variable.patch \
21 file://0003-mbedtls-Disable-documentation-warning-as-error-with-.patch \
22 file://0004-Use-correct-type-to-store-return-from-flb_kv_item_cr.patch \
23 file://0005-stackdriver-Fix-return-type-mismatch.patch \
24 file://0006-monkey-Fix-TLS-detection-testcase.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050025 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050026SRC_URI:remove:x86 = "file://0002-mbedtls-Remove-unused-variable.patch"
Patrick Williams92b42cb2022-09-03 06:53:57 -050027SRC_URI:append:libc-musl = "\
28 file://0001-Use-posix-strerror_r-with-musl.patch \
29 file://0002-chunkio-Link-with-fts-library-with-musl.patch \
30 "
31SRC_URI[sha256sum] = "8ca2ac081d7eee717483c06608adcb5e3d5373e182ad87dba21a23f8278c6540"
32S = "${WORKDIR}/fluent-bit-${PV}"
33
34DEPENDS = "zlib bison-native flex-native openssl"
35DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
36
37PACKAGECONFIG[yaml] = "-DFLB_CONFIG_YAML=On,-DFLB_CONFIG_YAML=Off,libyaml"
38PACKAGECONFIG[kafka] = "-DFLB_OUT_KAFKA=On,-DFLB_OUT_KAFKA=Off,librdkafka"
39PACKAGECONFIG[examples] = "-DFLB_EXAMPLES=On,-DFLB_EXAMPLES=Off"
40PACKAGECONFIG[jemalloc] = "-DFLB_JEMALLOC=On,-DFLB_JEMALLOC=Off,jemalloc"
41#TODO add more fluentbit options to PACKAGECONFIG[]
42
43DEPENDS:append:libc-musl = " fts "
44
45# flex hardcodes the input file in #line directives leading to TMPDIR contamination of debug sources.
46do_compile:append() {
47 find ${B} -name '*.c' -or -name '*.h' | xargs sed -i -e 's|${TMPDIR}|/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/|g'
48}
49
50PACKAGECONFIG ?= "yaml"
51
52LTO = ""
53
54# Use CMake 'Unix Makefiles' generator
55OECMAKE_GENERATOR ?= "Unix Makefiles"
56
57# Fluent Bit build options
58# ========================
59
60# Host related setup
61EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_TD=1"
62
63# Disable LuaJIT and filter_lua support
64EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off "
65
66# Disable Library and examples
67EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off"
68
69# Enable systemd iff systemd is in DISTRO_FEATURES
70EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On','-DFLB_SYSTEMD=Off',d)}"
71
72# Enable release builds
73EXTRA_OECMAKE += "-DFLB_RELEASE=On"
74
75# musl needs these options
76EXTRA_OECMAKE:append:libc-musl = ' -DFLB_JEMALLOC_OPTIONS="--with-jemalloc-prefix=je_ --with-lg-quantum=3" -DFLB_CORO_STACK_SIZE=24576'
77
78EXTRA_OECMAKE:append:riscv64 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
79EXTRA_OECMAKE:append:riscv32 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
80EXTRA_OECMAKE:append:mips = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
Andrew Geissler517393d2023-01-13 08:55:19 -060081EXTRA_OECMAKE:append:powerpc = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
Patrick Williams92b42cb2022-09-03 06:53:57 -050082EXTRA_OECMAKE:append:x86 = " -DCMAKE_C_STANDARD_LIBRARIES=-latomic"
83
84CFLAGS:append:x86 = " -DMBEDTLS_HAVE_SSE2"
85
86inherit cmake systemd pkgconfig
87
88SYSTEMD_SERVICE:${PN} = "td-agent-bit.service"
89
90EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
91TARGET_CC_ARCH += " ${SELECTED_OPTIMIZATION}"