blob: 4e396d83e987fd682018efa8725efab41dfb33d2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "libdecor - A client-side decorations library for Wayland clients"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=7ae2be7fb1637141840314b51970a9f7"
4
5SRC_URI = "git://gitlab.gnome.org/jadahl/libdecor.git;protocol=https;branch=master"
6
7DEPENDS = " \
8 cairo \
9 pango \
10 wayland \
11 wayland-native \
12 wayland-protocols \
13"
14
15S = "${WORKDIR}/git"
16SRCREV = "e87dcfdaf83f332fa83b43c804fcf93c151ff0f5"
17
18PACKAGECONFIG ?= "dbus ${@bb.utils.filter('DISTRO_FEATURES', 'gtk3 opengl', d)}"
19
20PACKAGECONFIG[dbus] = "-Ddbus=enabled,-Ddbus=disabled,dbus"
21PACKAGECONFIG[demo] = "-Ddemo=true,-Ddemo=false,virtual/libegl libxkbcommon"
22PACKAGECONFIG[gtk3] = "-Dgtk=enabled,-Dgtk=disabled,gtk+3"
23PACKAGECONFIG[opengl] = ",,virtual/libgl"
24
25inherit meson pkgconfig
26
27EXTRA_OEMESON += "--buildtype release"
28
29BBCLASSEXTEND = "native nativesdk"