blob: 939f3f36e5941eb78ed6fec744487db3286aced2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
2LICENSE = "LGPL-3.0-only"
3LIC_FILES_CHKSUM = "file://../COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://../COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5 file://../COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
6 "
7
8SRC_URI = "git://github.com/libyui/libyui.git;branch=master;protocol=https \
9 file://0001-Fix-build-with-clang.patch \
10 file://0001-Use-relative-install-paths-for-CMake.patch \
11 "
12
13SRCREV = "dabdcd9cc6a0058fd6966d7d2e19d508debcc0ac"
14
15S = "${WORKDIR}/git/libyui"
16
17inherit cmake gettext pkgconfig
18
19DEPENDS += "boost"
20
21EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RELWITHDEBINFO -DWERROR=OFF"
22
23BBCLASSEXTEND = "native nativesdk"
24
25do_install:append () {
26 if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
27 mv ${D}/usr/lib64 ${D}/usr/lib
28 fi
29}
30
31do_install:append:class-nativesdk () {
32 mkdir -p ${D}/${base_prefix}
33 mv ${D}/usr ${D}/${base_prefix}
34}
35
36FILES:${PN}-dev = "${libdir}/* ${includedir}/yui*"