blob: 50d73df03ac785beb2a1689da11a7780f32b6f61 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "User-space front-end command-line tool for ftrace"
2
3LICENSE = "GPL-2.0-only & LGPL-2.1-only"
4LIC_FILES_CHKSUM = " \
5 file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
6 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd \
7 "
8
9SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git;branch=master \
10 file://0001-Replace-LFS64-interfaces-off64_t-and-lseek64.patch \
11 file://0001-Do-not-emit-useless-rpath.patch"
12SRCREV = "18233e4c32857cb7ddd4960beeec8360ed834fc5"
13
14S = "${WORKDIR}/git"
15
16DEPENDS += "libtraceevent libtracefs zstd xmlto-native asciidoc-native swig-native bison-native flex-native"
17
18inherit pkgconfig bash-completion
19
20TARGET_CC_ARCH += "${LDFLAGS}"
21
22do_compile() {
23 oe_runmake libdir_relative=${BASELIB} libs
24 oe_runmake libdir_relative=${BASELIB} all
25}
26
27do_install() {
28 oe_runmake libdir_relative=${BASELIB} etcdir=${sysconfdir} pkgconfig_dir=${libdir}/pkgconfig DESTDIR=${D} install install_libs
29 # Because makefile uses cp instead of install we need to change owner of files
30 chown -R root:root ${D}${libdir}
31}