blob: 9882ba6f8ec8a137938f4a8e5b90e51f1209acc3 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Small and fast POSIX-compliant shell"
2HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
3SECTION = "System Environment/Shells"
4
5LICENSE = "BSD-3-Clause & GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
7
8inherit autotools update-alternatives
9
10SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz"
11SRC_URI[sha256sum] = "6a474ac46e8b0b32916c4c60df694c82058d3297d8b385b74508030ca4a8f28a"
12
13EXTRA_OECONF += "--bindir=${base_bindir}"
14
15ALTERNATIVE:${PN} = "sh"
16ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
17ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
18ALTERNATIVE_PRIORITY = "10"
19
20pkg_postinst:${PN} () {
21 grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
22}
23
24pkg_postrm:${PN} () {
25 printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
26}