blob: 1a565636d5fa31113d5e88e18d08520cf7523894 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "A microbenchmark support library"
2HOMEPAGE = "https://github.com/google/benchmark"
3SECTION = "libs"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI = "git://github.com/google/benchmark.git;protocol=https;branch=main"
8SRCREV = "d572f4777349d43653b21d6c2fc63020ab326db2"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OECMAKE = " \
13 -DBUILD_SHARED_LIBS=yes \
14 -DBENCHMARK_ENABLE_TESTING=no \
15 -DCMAKE_BUILD_TYPE=Release \
16"
17
18inherit cmake
19
20FILES:${PN}-dev += "${libdir}/cmake"