blob: d37b73af28004b858482c09530d08218b27a009d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Hardware identification and configuration data"
2HOMEPAGE = "https://github.com/vcrhonek/hwdata"
3SECTION = "System/Base"
4
5LICENSE = "GPL-2.0-or-later | XFree86-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
7
8SRCREV = "803068db92b8bb249014f1c947b91b452f539f5f"
9SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
10
11S = "${WORKDIR}/git"
12
13inherit allarch
14
15do_configure() {
16 ${S}/configure --datadir=${datadir} --libdir=${libdir}
17}
18
19do_compile[noexec] = "1"
20
21do_install() {
22 oe_runmake install DESTDIR=${D}
23}
24
25FILES:${PN} = "${libdir}/* \
26 ${datadir}/* "