blob: eb23816e8ab6f3398f31d90b7fc07c1e2ebd861f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "IMAPFilter is a mail filtering utility that processes mailboxes based on IMAP queries"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=c11d4fd926d3ce7aac13b0ed1e9b3a63"
4
5# v2.7.6
6SRCREV = "b39d0430f29d7c953581186955c11b461e6c824f"
7SRC_URI = "git://github.com/lefcha/imapfilter;protocol=https;branch=master \
8 file://ldflags.patch \
9"
10S = "${WORKDIR}/git"
11
12DEPENDS= "openssl lua libpcre2"
13
14EXTRA_OEMAKE:append = " PREFIX=${prefix}"
15
16do_install(){
17 oe_runmake DESTDIR=${D} install
18
19 # No need for manuals at this point, MANDIR is hardcoded to depend on prefix
20 rm -rf ${D}${prefix}/man
21}
22
23ASNEEDED = ""