blob: 1ce28f1f04b3f7a23e06b0e5b14a782a1210e9e0 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Satyr is a collection of low-level algorithms for program \
2failure processing, analysis, and reporting supporting kernel space, user \
3space, Python, and Java programs"
4
5HOMEPAGE = "https://github.com/abrt/satyr"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
Andrew Geissler517393d2023-01-13 08:55:19 -06008inherit autotools-brokensep python3native python3targetconfig pkgconfig
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10SRC_URI = "git://github.com/abrt/satyr.git;branch=master;protocol=https \
11 file://0002-fix-compile-failure-against-musl-C-library.patch \
Patrick Williams7784c422022-11-17 07:29:11 -060012 "
13SRCREV = "61addf12d15ef9d0bff5e3cc26e08d08a4f88094"
Andrew Geissler595f6302022-01-24 19:11:47 +000014S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
17
18DEPENDS += " \
19 gdb \
20 gperf-native \
21 json-c \
22 nettle \
23 glib-2.0 \
24"
25
26PACKAGES += "python3-${BPN}"
27FILES:python3-${BPN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}"
28
29PACKAGECONFIG ??= "python3 rpm"
30PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
31PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm"
32
33do_configure:prepend() {
34 ${S}/gen-version
35}