blob: ec985fb039b3ff9700ce500587cd6bb82824695e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Very fast, header only, C++ logging library."
2HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRCREV = "ad0e89cbfb4d0c1ce4d097e134eb7be67baebb36"
7SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x \
8 file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch \
9 "
10
11DEPENDS += "fmt"
12
13S = "${WORKDIR}/git"
14
15BBCLASSEXTEND = "native"
16# no need to build example & tests & benchmarks on pure yocto
17EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on"
18
19inherit cmake