blob: 84e04e9f2e440285e38b398f34b1a9539027ac2c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "A portal frontend service for Flatpak and possibly other desktop containment frameworks."
2HOMEPAGE = "https://github.com/flatpak/xdg-desktop-portal"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6REQUIRED_DISTRO_FEATURES = "polkit"
7
8DEPENDS = " \
9 json-glib \
10 glib-2.0 \
11 libportal \
12 geoclue \
13 pipewire \
14 dbus-native \
15 fuse3 \
16 bubblewrap-native \
17 xmlto-native \
18 flatpak \
19 python3-dbus-native \
20"
21
22PORTAL_BACKENDS ?= " \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'xdg-desktop-portal-wlr', '', d)} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'gtk', 'xdg-desktop-portal-gnome', '', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'gtk+3', 'xdg-desktop-portal-gnome', '', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'gtk4', 'xdg-desktop-portal-gnome', '', d)} \
27"
28
29RDEPENDS:${PN} = "bubblewrap ${PORTAL_BACKENDS}"
30
31inherit meson pkgconfig python3native features_check
32
33SRC_URI = " \
34 git://github.com/flatpak/xdg-desktop-portal.git;protocol=https;branch=main \
35 file://0001-xdg-desktop-portal-pc-in-add-pc_sysrootdir-dir.patch \
36"
37
38S = "${WORKDIR}/git"
39SRCREV = "88af6c8ca4106fcf70925355350a669848e9fd5a"
40
41FILES:${PN} += "${libdir}/systemd ${datadir}/dbus-1"