blob: f1028074d74991bc8c5547aac5a78b53a869f901 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
7
8SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \
9 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
10 file://0003-Remove-Werror-from-build.patch \
11 file://0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
12 file://0005-Undefine-PAGE_SIZE.patch \
13 file://0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
14 file://0001-libfwtsiasl-Disable-parallel-builds-of-lex-bison-fil.patch \
15 "
16SRC_URI[sha256sum] = "4af4e1e0f1ae9313297af722d744ba47a81c81bc5bdeab3f4f40837a39e4b808"
17
18COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
19
20DEPENDS = "libpcre glib-2.0 dtc bison-native flex-native libbsd"
21DEPENDS:append:libc-musl = " libexecinfo"
22
23inherit autotools bash-completion pkgconfig
24
25LDFLAGS:append:libc-musl = " -lexecinfo"
26
27# We end up linker barfing with undefined symbols on ppc64 but not on other arches
28# surprisingly
29ASNEEDED:powerpc64le = ""
30
31FILES:${PN} += "${libdir}/fwts/lib*${SOLIBS}"
32FILES:${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
33FILES:${PN}-staticdev += "${libdir}/fwts/lib*a"
34
35RDEPENDS:${PN} += "dtc"